tar: do not build SELinux support for host variant
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 29 Dec 2017 20:26:08 +0000 (21:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 30 Dec 2017 21:33:53 +0000 (22:33 +0100)
If we don't explicitly disable SELinux support in the host-tar build,
it might pick up system-wide installed SELinux libraries, causing the
tar in HOST_DIR/bin/ to depend on the host SELinux libraries, which is
not desirable to make the SDK portable/relocatable.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tar/tar.mk

index cb2ddc0ecab2da595ef26d4fad63e5eb49e20147..a8a15d9518d25d874b8619678cff7b11fc3baab3 100644 (file)
@@ -44,4 +44,7 @@ define HOST_TAR_EXTRACT_CMDS
        mv $(@D)/tar-$(TAR_VERSION)/* $(@D)
        rmdir $(@D)/tar-$(TAR_VERSION)
 endef
+
+HOST_TAR_CONF_OPTS = --without-selinux
+
 $(eval $(host-autotools-package))