glibc: add debug symbols when BR2_ENABLE_DEBUG
authorBaruch Siach <baruch@tkos.co.il>
Thu, 1 Jan 2015 10:16:43 +0000 (12:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Jan 2015 21:59:12 +0000 (22:59 +0100)
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/glibc/glibc.mk

index 65f4ed3b0d97e7a5f75a9931cd6156105e121404..0a37bb361a0705cc6cf741898a6e6367c6697fcc 100644 (file)
@@ -47,6 +47,10 @@ else ifeq ($(BR2_MIPS_OABI32),y)
 GLIBC_EXTRA_CFLAGS += -mabi=32
 endif
 
+ifeq ($(BR2_ENABLE_DEBUG),y)
+GLIBC_EXTRA_CFLAGS += -g
+endif
+
 # The stubs.h header is not installed by install-headers, but is
 # needed for the gcc build. An empty stubs.h will work, as explained
 # in http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html. The same trick