package/frotz: new package
authorThomas Huth <huth@tuxfamily.org>
Thu, 30 Apr 2020 14:44:41 +0000 (16:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 9 Jan 2021 22:24:09 +0000 (23:24 +0100)
Frotz is an interpreter for old Infocom adventures and other Z-code
games.

Signed-off-by: Thomas Huth <huth@tuxfamily.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/frotz/Config.in [new file with mode: 0644]
package/frotz/frotz.hash [new file with mode: 0644]
package/frotz/frotz.mk [new file with mode: 0644]

index 64ce5b7d4487e376c6d20a6be31a1b77c4603440..bf8118ef7dcbb86179257bcff84a054b83abeee9 100644 (file)
@@ -2564,6 +2564,7 @@ F:        toolchain/
 
 N:     Thomas Huth <huth@tuxfamily.org>
 F:     package/ascii-invaders/
+F:     package/frotz/
 F:     package/xorcurses/
 
 N:     Thomas Petazzoni <thomas.petazzoni@bootlin.com>
index 9709eaa3775498646a4a57b731647c5d6be292e9..f497fbffde20f1d88769d394dc846674afe60286 100644 (file)
@@ -265,6 +265,7 @@ menu "Games"
        source "package/doom-wad/Config.in"
        source "package/flare-engine/Config.in"
        source "package/flare-game/Config.in"
+       source "package/frotz/Config.in"
        source "package/gnuchess/Config.in"
        source "package/lbreakout2/Config.in"
        source "package/ltris/Config.in"
diff --git a/package/frotz/Config.in b/package/frotz/Config.in
new file mode 100644 (file)
index 0000000..59b6d00
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_FROTZ
+       bool "frotz"
+       select BR2_PACKAGE_NCURSES
+       help
+         Frotz is an interpreter for old Infocom adventure games and
+         other Z-code games. Note that frotz can not be run as root.
+         You must add a normal user to your buildroot configuration to
+         be able to use it.
+
+         https://661.org/proj/if/frotz/
diff --git a/package/frotz/frotz.hash b/package/frotz/frotz.hash
new file mode 100644 (file)
index 0000000..14f1a7f
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  7e488140791259a1a8c9e16a0c467ca69b694b918c28ffe3d83c654bcb253cca  frotz-2.51.tar.bz2
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/frotz/frotz.mk b/package/frotz/frotz.mk
new file mode 100644 (file)
index 0000000..ce27bdf
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# Frotz
+#
+################################################################################
+
+FROTZ_VERSION = 2.51
+FROTZ_SOURCE = frotz-$(FROTZ_VERSION).tar.bz2
+FROTZ_SITE = https://gitlab.com/DavidGriffith/frotz/-/archive/$(FROTZ_VERSION)
+FROTZ_DEPENDENCIES = host-pkgconf ncurses
+FROTZ_LICENSE = GPL-2.0+
+FROTZ_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
+FROTZ_CURSES=ncursesw
+FROTZ_UTF8=yes
+else
+FROTZ_CURSES=ncurses
+endif
+
+define FROTZ_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) PREFIX=/usr CONFIG_DIR=/etc \
+               SOUND_TYPE=none CURSES="$(FROTZ_CURSES)" USE_UTF8=$(FROTZ_UTF8) \
+               CFLAGS="$(TARGET_CFLAGS) -std=c99"
+endef
+
+define FROTZ_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/frotz $(TARGET_DIR)/usr/bin/frotz
+endef
+
+$(eval $(generic-package))