package/qextserialport: remove qt4 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:54 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:41:36 +0000 (15:41 +0100)
Qt4 support is about to be dropped, so remove the support from
qextserialport as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qextserialport/Config.in
package/qextserialport/qextserialport.mk

index 4e7ef137846ee27363f74111929ea59a3281d354..f880d335e5124f1d1de73109e2d54b0054eba085 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_QEXTSERIALPORT
        bool "qextserialport"
-       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5
        help
          A Qt library to manage serial ports
 
index e3e325ce6c1d3f65365e340b94d9c650beddbced..ecaff21efc879df6a9dd622f64b694fb85a7e4cb 100644 (file)
@@ -14,16 +14,10 @@ ifeq ($(BR2_STATIC_LIBS),y)
 QEXTSERIALPORT_CONF_OPTS += CONFIG+=qesp_static
 endif
 
-ifeq ($(BR2_PACKAGE_QT),y)
-QEXTSERIALPORT_DEPENDENCIES += qt
-QEXTSERIALPORT_QMAKE = $(QT_QMAKE)
-else ifeq ($(BR2_PACKAGE_QT5),y)
-QEXTSERIALPORT_DEPENDENCIES += qt5base
-QEXTSERIALPORT_QMAKE = $(QT5_QMAKE)
-endif
+QEXTSERIALPORT_DEPENDENCIES = qt5base
 
 define QEXTSERIALPORT_CONFIGURE_CMDS
-       cd $(@D); $(TARGET_MAKE_ENV) $(QEXTSERIALPORT_QMAKE) $(QEXTSERIALPORT_CONF_OPTS)
+       cd $(@D); $(TARGET_MAKE_ENV) $(QT5_QMAKE) $(QEXTSERIALPORT_CONF_OPTS)
 endef
 
 define QEXTSERIALPORT_BUILD_CMDS