package/oprofile: fix static linking
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Aug 2015 21:46:38 +0000 (23:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 17 Aug 2015 20:28:00 +0000 (22:28 +0200)
When getext is enabled, popt links with -lintl, specifies it in its
popt.pc and has done so for the past 6+ years. But oprofile does not
use pkconfig to find popt, so misses -lintl, which is important for
a static build. We have to do the call to pkgconfig manually...

Fixes:
    http://autobuild.buildroot.org/results/a48/a485f2171a3fcbfa2e0e5aec8e653cf88512615d/
    http://autobuild.buildroot.org/results/b37/b374874f1915ab1d7aa6262604ccc8db102bb0b0/
    http://autobuild.buildroot.org/results/261/2616a63081ed8c55c7ca1a6879b1a6a14e19f918/
    http://autobuild.buildroot.org/results/73f/73f34ab59d54ded68ff60608a0212a6e5a5190e5/
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/oprofile/oprofile.mk

index 5876307e489752e3344ede1b2f1c2c3446fafa47..ba366403d230c35d080c3706aab63bc607ab3b27 100644 (file)
@@ -41,6 +41,12 @@ ifeq ($(BR2_PACKAGE_LIBPFM4),y)
 OPROFILE_DEPENDENCIES += libpfm4
 endif
 
+# When getext is enabled, popt links with -lintl, specifies it in its
+# popt.pc and has done so for the past 6+ years. But oprofile does not
+# use pkconfig to find popt, so misses -lintl, which is important for
+# a static build. We have to do the call to pkgconfig manually...
+OPROFILE_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs popt`"
+
 define OPROFILE_INSTALL_TARGET_CMDS
        $(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
        $(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile