package/php: add config scan directory option
authorDan Walkes <danwalkes@trellis-logic.com>
Sun, 19 May 2019 00:19:42 +0000 (18:19 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 18:16:30 +0000 (19:16 +0100)
To support using multiple php configuration files, we pass
--with-config-file-scan-dir=/etc/php.d. This allows to put snippets of
PHP configuration files in /etc/php.d.

For php option details see link at [1].

[1] https://www.php.net/manual/en/configuration.file.php

Signed-off-by: Dan Walkes <danwalkes@trellis-logic.com>
[Thomas: make it unconditional]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/php/php.mk

index 0213295c82958eaa97476445d94f568403c718e8..b679531238283dc12ab7c6c062255c9bf2947095 100644 (file)
@@ -16,6 +16,7 @@ PHP_LICENSE_FILES = LICENSE
 PHP_CONF_OPTS = \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
+       --with-config-file-scan-dir=/etc/php.d \
        --disable-all \
        --without-pear \
        --with-config-file-path=/etc \