libstrophe: add a patch to fix static builds
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 28 Sep 2015 09:17:13 +0000 (10:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Sep 2015 19:27:48 +0000 (21:27 +0200)
libstrophe.a and libcrypto.a have symbols with equal names, so
executables can't be statically linked with libstrophe and openssl:

sha1dgst.c:(.text+0x1b4c): multiple definition of `SHA1_Update'
sha1dgst.c:(.text+0x1cc0): multiple definition of `SHA1_Final'
sha1dgst.c:(.text+0x1e78): multiple definition of `SHA1_Init

Renaming the internal SHA functions fixes the problem.

Issue reported upstream:

  https://github.com/strophe/libstrophe/issues/40

Fixes:

  http://autobuild.buildroot.net/results/047/047e319b9d7bf0cdaabc007326a6d67de2c1ee52/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libstrophe/libstrophe.mk

index e6eb8346b30d63011a3986d44be6424cbf0bf583..60e29d38c33d1ee1488e75f0d756f6494ce4cca9 100644 (file)
@@ -12,6 +12,7 @@ LIBSTROPHE_AUTORECONF = YES
 LIBSTROPHE_LICENSE = MIT or GPLv3
 LIBSTROPHE_LICENSE_FILES = MIT-LICENSE.txt GPL-LICENSE.txt
 LIBSTROPHE_INSTALL_STAGING = YES
+LIBSTROPHE_PATCH = https://github.com/msantos/libstrophe/commit/b08766c8e46956daba010044b00c97f78b598780.patch
 
 ifeq ($(BR2_PACKAGE_EXPAT),y)
 # Passing --without-libxml2 doesn't work, due to how AC_ARG_WITH is