package/efl/libefl: add webp dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 15 Dec 2015 22:40:16 +0000 (23:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 22:52:59 +0000 (23:52 +0100)
WebP is a new image format that provides lossless and lossy
compression for images on the web. So enabling webp support in efl
libraries allow to loads images using WebP.

Also, it one of the "highly recommended" dependencies [1] according to
the README but disabling it doesn't need the
--enable-i-really-know-what-i-am-doing... option.  That's why
BR2_PACKAGE_LIBEFL_WEBP is not added to
BR2_PACKAGE_LIBEFL_HAS_RECOMMENDED_CONFIG.

[1] https://git.enlightenment.org/core/efl.git/tree/README?id=v1.15.2#n486

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libefl/Config.in
package/efl/libefl/libefl.mk

index 7d635d97369ec07de9f135d9bf2905fc2c59236e..41b12435be98b518eaf4a9b4900245d0308a5111 100644 (file)
@@ -137,4 +137,10 @@ config BR2_PACKAGE_LIBEFL_TIFF
        help
          This enables the loader code that loads tiff files.
 
+config BR2_PACKAGE_LIBEFL_WEBP
+       bool "libevas webp image loader"
+       select BR2_PACKAGE_WEBP
+       help
+         This enables the loader code that loads images using WebP.
+
 endif # BR2_PACKAGE_LIBEFL
index e21d89cea90e5f48fe51ac511408fe2e4ac56fee..2ebf6fb14213e19a27a44c3f7e52adbb36c7be06 100644 (file)
@@ -32,7 +32,6 @@ LIBEFL_GETTEXTIZE = YES
 # --disable-cxx-bindings: disable C++11 bindings.
 # --disable-fb: disable frame buffer support.
 # --disable-image-loader-jp2k: disable JPEG 2000 support.
-# --disable-image-loader-webp: disable webp support.
 # --disable-sdl: disable sdl2 support.
 # --disable-systemd: disable systemd support.
 # --enable-lua-old: disable Elua and remove luajit dependency.
@@ -44,7 +43,6 @@ LIBEFL_CONF_OPTS = \
        --disable-cxx-bindings \
        --disable-fb \
        --disable-image-loader-jp2k \
-       --disable-image-loader-webp \
        --disable-sdl \
        --disable-systemd \
        --enable-lua-old \
@@ -176,6 +174,13 @@ else
 LIBEFL_CONF_OPTS += --disable-image-loader-tiff
 endif
 
+ifeq ($(BR2_PACKAGE_LIBEFL_WEBP),y)
+LIBEFL_CONF_OPTS += --enable-image-loader-webp=yes
+LIBEFL_DEPENDENCIES += webp
+else
+LIBEFL_CONF_OPTS += --disable-image-loader-webp
+endif
+
 $(eval $(autotools-package))
 
 ################################################################################