lua-ev: New package
authorAssaf Inbal <shmuelzon@gmail.com>
Mon, 17 Jun 2013 05:55:48 +0000 (08:55 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Jun 2013 21:13:41 +0000 (23:13 +0200)
Lua bindings for libev

[Peter: fix file header]
Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/lua-ev/Config.in [new file with mode: 0644]
package/lua-ev/lua-ev.mk [new file with mode: 0644]

index 2d32a9ff163a72ca32bd2d0b29f411eadf88cc2e..92927e398cf1fbbbf8694eeefee3cbf72cb75631 100644 (file)
@@ -320,6 +320,7 @@ source "package/luacjson/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luafilesystem/Config.in"
 source "package/luasocket/Config.in"
+source "package/lua-ev/Config.in"
 source "package/lua-msgpack-native/Config.in"
 source "package/rings/Config.in"
 source "package/wsapi/Config.in"
diff --git a/package/lua-ev/Config.in b/package/lua-ev/Config.in
new file mode 100644 (file)
index 0000000..1e89c27
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_EV
+       bool "lua-ev"
+       select BR2_PACKAGE_LIBEV
+       help
+         Get access to the libev library from Lua.
+
+         https://github.com/brimworks/lua-ev
diff --git a/package/lua-ev/lua-ev.mk b/package/lua-ev/lua-ev.mk
new file mode 100644 (file)
index 0000000..2b03936
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lua-ev
+#
+################################################################################
+
+LUA_EV_VERSION = 458165b
+LUA_EV_SITE = http://github.com/brimworks/lua-ev/tarball/$(LUA_EV_VERSION)
+LUA_EV_DEPENDENCIES = lua libev
+LUA_EV_LICENSE = MIT
+LUA_EV_LICENSE_FILES = README
+LUA_EV_CONF_OPT = -DINSTALL_CMOD="/usr/lib/lua"
+
+$(eval $(cmake-package))