strongswan: disable iptables support
authorWaldemar Brodkorb <wbx@openadk.org>
Mon, 4 Apr 2016 08:19:55 +0000 (10:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 13 Apr 2016 21:55:56 +0000 (23:55 +0200)
There is a new conflict between Linux header (linux/if.h)
and C library header (net/if.h) introduced by this commit
to the Linux kernel:
1ffad83dffd675cd742286ae82dca7d746cb0da8
Mikko Rapeli is working on a solution, but it requires
changes to the Linux kernel and C library.

For now I would just disable the iptables feature in Strongswan.

The changes fixes following autobuild error:
http://autobuild.buildroot.net/results/e1693a714eb690988c1798b733d0ff143e50b3b9/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/strongswan/strongswan.mk

index e27606cc1669f3f2c28f1a68c9362d23390907f4..e7606c008ffe1b5f3bc7d6db6b0db9a8beb70097 100644 (file)
@@ -71,15 +71,10 @@ STRONGSWAN_DEPENDENCIES += \
        $(if $(BR2_PACKAGE_MYSQL),mysql)
 endif
 
-ifeq ($(BR2_PACKAGE_IPTABLES),y)
-STRONGSWAN_DEPENDENCIES += iptables
+# disable connmark/forecast until net/if.h vs. linux/if.h conflict resolved
+# problem exist since linux 4.5 header changes
 STRONGSWAN_CONF_OPTS += \
-       --enable-connmark \
-       --enable-forecast
-else
-STRONGSWAN_COF_OPTS += \
        --disable-connmark \
        --disable-forecast
-endif
 
 $(eval $(autotools-package))