psplash: new package
authorPhil Eichinger <phil.eichinger@gmail.com>
Tue, 1 Oct 2013 15:07:46 +0000 (17:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Oct 2013 19:19:42 +0000 (21:19 +0200)
Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/psplash/Config.in [new file with mode: 0644]
package/psplash/psplash.mk [new file with mode: 0644]

index c6ea66bdb13b64b9786f0b1a335a5ccfe6ee6c12..da10a2363f4afcd3d6a3c0e0f30b8f9eeee1dd92 100644 (file)
@@ -160,6 +160,7 @@ source "package/imagemagick/Config.in"
 source "package/linux-fusion/Config.in"
 source "package/lite/Config.in"
 source "package/ocrad/Config.in"
+source "package/psplash/Config.in"
 source "package/sawman/Config.in"
 source "package/sdl/Config.in"
 source "package/sdl_image/Config.in"
diff --git a/package/psplash/Config.in b/package/psplash/Config.in
new file mode 100644 (file)
index 0000000..73fcfee
--- /dev/null
@@ -0,0 +1,31 @@
+config BR2_PACKAGE_PSPLASH
+       bool "psplash"
+       depends on BR2_USE_WCHAR
+       help
+         PSplash is a userspace graphical boot splash screen for mainly
+         embedded Linux devices supporting a 16bpp or 32bpp framebuffer.
+         It has few dependencies (just libc), supports basic images and
+         text and handles rotation. Its visual look is configurable by
+         basic source changes.
+
+         Also included is a 'client' command utility for sending
+         information to psplash such as boot progress information.
+
+         Start the drawing process with 'psplash -n&' as early as possible.
+         Note: psplash creates a FIFO in /tmp for communication with
+         psplash-write.
+
+         Usage:
+         * Set progress bar to 50 percent:
+           psplash-write "PROGRESS 50"
+
+         * Display message "foobar" above progress bar:
+           psplash-write "MSG foobar"
+
+         * Terminate psplash:
+           psplash-write "QUIT"
+
+         http://git.yoctoproject.org/cgit/cgit.cgi/psplash/
+
+comment "psplash requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/psplash/psplash.mk b/package/psplash/psplash.mk
new file mode 100644 (file)
index 0000000..cb1c54a
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# psplash
+#
+################################################################################
+
+PSPLASH_VERSION = 0.1
+PSPLASH_SITE = http://downloads.yoctoproject.org/releases/psplash
+PSPLASH_LICENSE = GPLv2+
+PSPLASH_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))