package/vlc: add optional dependency to libsoxr
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:31 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:42 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index f777d86bda789aedd12e8a52e3b3573901e33ee4..a15bda3204e2ef8559cc50ec43a817edb86b10aa 100644 (file)
@@ -74,7 +74,6 @@ VLC_CONF_OPTS += \
        --disable-notify \
        --disable-projectm \
        --disable-schroedinger \
-       --disable-soxr \
        --disable-shine \
        --disable-shout \
        --disable-skins2 \
@@ -344,6 +343,13 @@ else
 VLC_CONF_OPTS += --disable-secret
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSOXR),y)
+VLC_CONF_OPTS += --enable-soxr
+VLC_DEPENDENCIES += libsoxr
+else
+VLC_CONF_OPTS += --disable-soxr
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
 VLC_CONF_OPTS += --enable-sftp
 VLC_DEPENDENCIES += libssh2