package/ffmpeg: prevent stripping the ffmpeg binary
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 10 Aug 2014 12:46:46 +0000 (14:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Aug 2014 09:02:57 +0000 (11:02 +0200)
Packages shouldn't strip executables by themselves, so that Buildroot
controls whether stripping should occur or not. This also fixes the
build on Blackfin FLAT where stripping actually doesn't work because
stripping FLAT binaries is not supported.

Inspired by Thomas:
http://git.buildroot.net/buildroot/commit/package/hdparm/hdparm.mk?id=11dbb615338cd768acc2c3138064ddf557e9b60b

Fixes
http://autobuild.buildroot.net/results/581/581c43b50c9717e53334eb156ece95fe499ccb04/
http://autobuild.buildroot.net/results/57a/57a1bdc22b803114c018fa007884385bf8355151/
http://autobuild.buildroot.net/results/d8a/d8a1aadebd302abc923bc4865e1242ab2479d641/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 5c269acb3b53e00507bedaab46df29f5fddb7062..e8d4adae3a865f7d217dc7da85469c54fe05e3b2 100644 (file)
@@ -329,6 +329,7 @@ define FFMPEG_CONFIGURE_CMDS
                --host-cc="$(HOSTCC)" \
                --arch=$(BR2_ARCH) \
                --target-os="linux" \
+               --disable-stripping \
                $(if $(BR2_GCC_TARGET_TUNE),--cpu=$(BR2_GCC_TARGET_TUNE)) \
                $(SHARED_STATIC_LIBS_OPTS) \
                $(FFMPEG_CONF_OPT) \