python-sortedcontainers: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 20 Mar 2017 14:36:20 +0000 (15:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Mar 2017 20:59:12 +0000 (21:59 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-sortedcontainers/Config.in [new file with mode: 0644]
package/python-sortedcontainers/python-sortedcontainers.hash [new file with mode: 0644]
package/python-sortedcontainers/python-sortedcontainers.mk [new file with mode: 0644]

index 9f4b550207f98212a5e0326442ee9d60e281210e..cd9d06dc1844607ab33ed464bc48e0cfb8d50530 100644 (file)
@@ -825,6 +825,7 @@ menu "External python modules"
        source "package/python-slob/Config.in"
        source "package/python-smbus-cffi/Config.in"
        source "package/python-socketio/Config.in"
+       source "package/python-sortedcontainers//Config.in"
        source "package/python-spidev/Config.in"
        source "package/python-thrift/Config.in"
        source "package/python-tomako/Config.in"
diff --git a/package/python-sortedcontainers/Config.in b/package/python-sortedcontainers/Config.in
new file mode 100644 (file)
index 0000000..43bd1b1
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_SORTEDCONTAINERS
+       bool "python-sortedcontainers"
+       help
+         Python Sorted Container Types: SortedList, SortedDict, and
+         SortedSet.
+
+         http://www.grantjenks.com/docs/sortedcontainers/
diff --git a/package/python-sortedcontainers/python-sortedcontainers.hash b/package/python-sortedcontainers/python-sortedcontainers.hash
new file mode 100644 (file)
index 0000000..11fa076
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/sortedcontainers/json, sha256 locally computed
+md5    ad4f00e377ad934954ac90fcac0b185f  sortedcontainers-1.5.7.tar.gz
+sha256 0ff0442865e492bc50476b18000fb8400cf2472d14d21a92b27cd7c5184550ea  sortedcontainers-1.5.7.tar.gz
diff --git a/package/python-sortedcontainers/python-sortedcontainers.mk b/package/python-sortedcontainers/python-sortedcontainers.mk
new file mode 100644 (file)
index 0000000..9960681
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-sortedcontainers
+#
+################################################################################
+
+PYTHON_SORTEDCONTAINERS_VERSION = 1.5.7
+PYTHON_SORTEDCONTAINERS_SOURCE = sortedcontainers-$(PYTHON_SORTEDCONTAINERS_VERSION).tar.gz
+PYTHON_SORTEDCONTAINERS_SITE = https://pypi.python.org/packages/8d/aa/5369362d730728639ba434318df26b5c554804578d1c48381367ea5377c6
+PYTHON_SORTEDCONTAINERS_SETUP_TYPE = setuptools
+PYTHON_SORTEDCONTAINERS_LICENSE = Apache-2.0
+PYTHON_SORTEDCONTAINERS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))