Makefile: don't export O to the environment
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 09:02:29 +0000 (10:02 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 09:04:21 +0000 (10:04 +0100)
Several projects use the kernel style O=<dir> syntax to build out of tree,
and atleast uClibc doesn't check that it was explictly passed on the command
line, so setting it in the environment breaks the build.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
docs/manual/customize-rootfs.txt

index 16b5ef41b316b7543572b2650cb19b0449f5cd69..f40863247d9c7b06dbc9d3e22ff3b41e9250780d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -291,7 +291,7 @@ export TARGET_DIR
 export STAGING_DIR
 export HOST_DIR
 export BINARIES_DIR
-export BASE_DIR O   # O and BASE_DIR are the same
+export BASE_DIR
 
 #############################################################
 #
index 4d3b559706832233029b1289c051dd03ace7f7ad..6399699bdc86e26c547bee9e12e42951add21fef 100644 (file)
@@ -43,7 +43,7 @@ there are a few ways to customize the resulting target filesystem.
       xref:generic-package-reference[]
     - +BINARIES_DIR+: the place where all binary files (aka images) are
       stored
-    - +BASE_DIR+ (or +O+): the base output directory
+    - +BASE_DIR+: the base output directory
 
 * A special package, 'customize', stored in +package/customize+ can be
   used. You can put all the files that you want to see in the final