package/efl/expedite: x-includes and x-libraries must be set for cross-compiling
authorRomain Naour <romain.naour@openwide.fr>
Wed, 6 May 2015 21:50:44 +0000 (23:50 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 7 May 2015 20:44:58 +0000 (22:44 +0200)
If those flags are not explicitly passed, the libecore configure
script will include -I/usr/X11R6/include and -L/usr/X11R6/lib in the
compile flags, which are obviously unsafe for cross-compilation.

The fix is similar to 0d9d8984a9240a27f5ed2e15f1977ada67266906 and
da50b6b61c4a566fd28888f5a3a6dcb06fe1b495.

Fixes:
http://autobuild.buildroot.org/results/24b/24b578a28455409b7bcc0277abc6b478c51ae67f

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/efl/expedite/expedite.mk

index f0361bf7b3f4e114e94dea280afe9e1d00d3a44c..02a4ca08c50213628312371ef7aad3ee6b542c06 100644 (file)
@@ -11,4 +11,10 @@ EXPEDITE_LICENSE_FILES = COPYING
 
 EXPEDITE_DEPENDENCIES = libevas libeina libeet
 
+ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
+EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
+endif
+
 $(eval $(autotools-package))