python-sqlalchemy: new package
authorAdam Duskett <aduskett@gmail.com>
Tue, 6 Feb 2018 13:25:03 +0000 (08:25 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 10 Feb 2018 15:19:29 +0000 (16:19 +0100)
SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that
gives application developers the full power and flexibility of SQL.

It provides a full suite of well known enterprise-level persistence
patterns, designed for efficient and high-performing database access,
adapted into a simple and Pythonic domain language.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
[Thomas: fix check-package warnings.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-sqlalchemy/Config.in [new file with mode: 0644]
package/python-sqlalchemy/python-sqlalchemy.hash [new file with mode: 0644]
package/python-sqlalchemy/python-sqlalchemy.mk [new file with mode: 0644]

index d0605af387570515bf07e4603c6661eecb1aa714..f859ebe984d5ad020dc73d45ceee005f6496d5d3 100644 (file)
@@ -52,6 +52,7 @@ F:    package/libsepol/
 F:     package/nginx-naxsi/
 F:     package/policycoreutils/
 F:     package/python-mutagen/
+F:     package/python-sqlalchemy/
 F:     package/restorecond/
 F:     package/refpolicy/
 F:     package/selinux-python/
index 5929cfea2d987baa06ae736dfea1d072bc27a2be..6bd95e3bf07b8c31e53554db85214a6cb94d22d7 100644 (file)
@@ -919,6 +919,7 @@ menu "External python modules"
        source "package/python-socketio/Config.in"
        source "package/python-sortedcontainers//Config.in"
        source "package/python-spidev/Config.in"
+       source "package/python-sqlalchemy/Config.in"
        source "package/python-systemd/Config.in"
        source "package/python-tabledata/Config.in"
        source "package/python-tempora/Config.in"
diff --git a/package/python-sqlalchemy/Config.in b/package/python-sqlalchemy/Config.in
new file mode 100644 (file)
index 0000000..f7ec3a6
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_PYTHON_SQLALCHEMY
+       bool "python-sqlalchemy"
+       help
+         SQLAlchemy is the Python SQL toolkit and Object Relational
+         Mapper that gives application developers the full power and
+         flexibility of SQL.
+
+         It provides a full suite of well known enterprise-level
+         persistence patterns, designed for efficient and
+         high-performing database access, adapted into a simple and
+         Pythonic domain language.
+
+         http://www.sqlalchemy.org
diff --git a/package/python-sqlalchemy/python-sqlalchemy.hash b/package/python-sqlalchemy/python-sqlalchemy.hash
new file mode 100644 (file)
index 0000000..9e13a2f
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/SQLAlchemy/json, sha256 locally computed
+md5    968e07dc0aa92f9205bb3877f33f498f  SQLAlchemy-1.2.2.tar.gz
+sha256 64b4720f0a8e033db0154d3824f5bf677cf2797e11d44743cf0aebd2a0499d9d  SQLAlchemy-1.2.2.tar.gz
+sha256 73bda3d7d6c568f494c1d12520a97d41a38b7ce91d88c21f1b469b747b17f7fd  LICENSE
diff --git a/package/python-sqlalchemy/python-sqlalchemy.mk b/package/python-sqlalchemy/python-sqlalchemy.mk
new file mode 100644 (file)
index 0000000..c002371
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-sqlalchemy
+#
+################################################################################
+
+PYTHON_SQLALCHEMY_VERSION = 1.2.2
+PYTHON_SQLALCHEMY_SOURCE = SQLAlchemy-$(PYTHON_SQLALCHEMY_VERSION).tar.gz
+PYTHON_SQLALCHEMY_SITE = https://pypi.python.org/packages/b9/fb/a56d2fc0ce3571328fa872734ad124cae25a4cea422088987f865fb71787
+PYTHON_SQLALCHEMY_SETUP_TYPE = setuptools
+PYTHON_SQLALCHEMY_LICENSE = MIT
+PYTHON_SQLALCHEMY_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))