make release: add html/text/pdf manual and create .tar.bz2 format as well
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 3 Feb 2012 21:03:29 +0000 (22:03 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Feb 2012 10:39:41 +0000 (11:39 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 7aeee962f83ebc5150ead74f502b8d5210ad7676..e1621f965e4ed9219f2167272d5f8e4d03781afe 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -695,8 +695,15 @@ endif
 
 release: OUT=buildroot-$(BR2_VERSION)
 
+# Create release tarballs. We need to fiddle a bit to add the generated
+# documentation to the git output
 release:
-       git archive --format=tar --prefix=$(OUT)/ master|gzip -9 >$(OUT).tar.gz
+       git archive --format=tar --prefix=$(OUT)/ master > $(OUT).tar
+       $(MAKE) O=$(OUT) manual-html manual-txt manual-pdf
+       tar rf $(OUT).tar $(OUT)
+       gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
+       bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
+       rm -rf $(OUT) $(OUT).tar
 
 ################################################################################
 # GENDOC -- generates the make targets needed to build a specific type of