package/python-periphery: new package
authorPierre-Jean Texier <pjtexier@koncepto.io>
Thu, 20 Jun 2019 18:38:13 +0000 (20:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 22 Jun 2019 15:51:01 +0000 (17:51 +0200)
Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-periphery/Config.in [new file with mode: 0644]
package/python-periphery/python-periphery.hash [new file with mode: 0644]
package/python-periphery/python-periphery.mk [new file with mode: 0644]

index aa55d7c1414a31f5aaad4b3909623396020c6c4d..2b0d185097f46520729d70371911b60a5c0c404c 100644 (file)
@@ -1860,6 +1860,7 @@ F:        package/trace-cmd/
 
 N:     Pierre-Jean Texier <pjtexier@koncepto.io>
 F:     package/libubootenv/
+F:     package/python-periphery/
 
 N:     Pieter De Gendt <pieter.degendt@gmail.com>
 F:     package/libvips/
index f980e979e360bf9bfb87ba05ae5e9b94a729db64..bc529e0b56788decd4b6c299786d360586d1722e 100644 (file)
@@ -966,6 +966,7 @@ menu "External python modules"
        source "package/python-pathpy/Config.in"
        source "package/python-pathtools/Config.in"
        source "package/python-pathvalidate/Config.in"
+       source "package/python-periphery/Config.in"
        source "package/python-pexpect/Config.in"
        source "package/python-pickleshare/Config.in"
        source "package/python-pigpio/Config.in"
diff --git a/package/python-periphery/Config.in b/package/python-periphery/Config.in
new file mode 100644 (file)
index 0000000..99585b0
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_PERIPHERY
+       bool "python-periphery"
+       help
+         A pure Python 2/3 library for peripheral I/O (GPIO, LED,
+         PWM, SPI, I2C, MMIO, Serial) in Linux.
+
+         https://github.com/vsergeev/python-periphery
diff --git a/package/python-periphery/python-periphery.hash b/package/python-periphery/python-periphery.hash
new file mode 100644 (file)
index 0000000..de988b3
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 a9a0a0ac02b8c3a954281777e92a15ec41abd311eb8732b50a2faaa9df62f1df  python-periphery-1.1.1.tar.gz
+sha256 db1bea825e728d8bcdf6c220d79c74370a9fcb63a4f9153c2cece2b63e177aa4  LICENSE
diff --git a/package/python-periphery/python-periphery.mk b/package/python-periphery/python-periphery.mk
new file mode 100644 (file)
index 0000000..150ac1c
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-periphery
+#
+################################################################################
+
+PYTHON_PERIPHERY_VERSION = 1.1.1
+PYTHON_PERIPHERY_SITE = $(call github,vsergeev,python-periphery,v$(PYTHON_PERIPHERY_VERSION))
+PYTHON_PERIPHERY_LICENSE = MIT
+PYTHON_PERIPHERY_LICENSE_FILES = LICENSE
+PYTHON_PERIPHERY_SETUP_TYPE = setuptools
+
+$(eval $(python-package))