libroxml: fix pthread linking issue
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Aug 2014 06:59:01 +0000 (08:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Aug 2014 06:59:01 +0000 (08:59 +0200)
Fixes http://autobuild.buildroot.net/results/d18/d188bcf5c374273ffe09589f7db5a40e4c5d7bc9/

Thread handling can get disabled with --disable-xml-thread-safe, but that's
a change for next.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libroxml/libroxml.mk

index 9a6c97a2559d62b778fc419c6c04f91cc979e10c..f30169fe39a38f9d77bbf79c88627144d396d044 100644 (file)
@@ -12,4 +12,8 @@ LIBROXML_LICENSE_FILES = License.txt
 
 LIBROXML_CONF_OPT = --disable-silent-rules
 
+# libroxml forgets to compile/link with -pthread, even though it uses
+# thread functions breaking static linking
+LIBROXML_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -pthread" LIBS="-pthread"
+
 $(eval $(autotools-package))