package/utf8proc: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Sep 2019 15:36:03 +0000 (17:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 10 Oct 2019 21:29:51 +0000 (23:29 +0200)
Needed for subversion 1.12.x:
https://github.com/apache/subversion/commit/472355d1597d7c1c64f20f72ed391fd34c0a8fb0

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/utf8proc/Config.in [new file with mode: 0644]
package/utf8proc/utf8proc.hash [new file with mode: 0644]
package/utf8proc/utf8proc.mk [new file with mode: 0644]

index 7e4d7fa94ad5ec864e4f61dd099955772cacd1c9..eedef2908877afc2ea55ddf2e4ac2e796f4ac0e2 100644 (file)
@@ -428,6 +428,7 @@ F:  package/tor/
 F:     package/transmission/
 F:     package/tvheadend/
 F:     package/unixodbc/
+F:     package/utf8proc/
 F:     package/vdr/
 F:     package/vdr-plugin-vnsiserver/
 F:     package/vlc/
index c3faa20d889f2a99c3c913d07c9d770b9c76e3f4..3a4b1c33bbed8d2374849c298aee220bc74d40fa 100644 (file)
@@ -1827,6 +1827,7 @@ menu "Text and terminal handling"
        source "package/readline/Config.in"
        source "package/slang/Config.in"
        source "package/tclap/Config.in"
+       source "package/utf8proc/Config.in"
 endmenu
 
 endmenu
diff --git a/package/utf8proc/Config.in b/package/utf8proc/Config.in
new file mode 100644 (file)
index 0000000..43b5073
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_UTF8PROC
+       bool "utf8proc"
+       help
+         A clean C library for processing UTF-8 Unicode data.
+
+         https://juliastrings.github.io/utf8proc
diff --git a/package/utf8proc/utf8proc.hash b/package/utf8proc/utf8proc.hash
new file mode 100644 (file)
index 0000000..da85a3c
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 b2e5d547c1d94762a6d03a7e05cea46092aab68636460ff8648f1295e2cdfbd7  utf8proc-2.4.0.tar.gz
+sha256 6acb7a86aca74317c6b4dddc2eadeb53bededb95a94a48c3fcd517f4473a653d  LICENSE.md
diff --git a/package/utf8proc/utf8proc.mk b/package/utf8proc/utf8proc.mk
new file mode 100644 (file)
index 0000000..2d60387
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# utf8proc
+#
+################################################################################
+
+UTF8PROC_VERSION = 2.4.0
+UTF8PROC_SITE = $(call github,JuliaStrings,utf8proc,v$(UTF8PROC_VERSION))
+UTF8PROC_LICENSE = MIT
+UTF8PROC_LICENSE_FILES = LICENSE.md
+UTF8PROC_INSTALL_STAGING = YES
+UTF8PROC_SUPPORTS_IN_SOURCE_BUILD = NO
+
+$(eval $(cmake-package))