libgpiod: bump version to v0.3
authorBartosz Golaszewski <brgl@bgdev.pl>
Sat, 24 Jun 2017 09:30:25 +0000 (11:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 24 Jun 2017 10:07:32 +0000 (12:07 +0200)
Add host-pkgconf to dependencies as we now use PKG_CHECK_MODULES in
configure.ac.

Changelog for v0.3:

New features:
- gpiomon can now watch multiple lines at the same time and supports custom
  output formats which can be specified using the --format argument
- testing framework can now test external programs: test cases for gpio-tools
  have been added

Improvements:
- improve error messages
- improve README examples
- configure script improvements

Bug fixes:
- use correct UAPI flags when requesting line events

Also includes bug fixes from v0.2.1:

Bug fixes:
- capitalize 'GPIO' in error messages in gpioset, gpioget & gpiomon
- tweak the error message on invalid arguments in gpiofind
- don't ignore superfluous arguments and fix the displayed name for falling
  edge events in gpiomon

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libgpiod/libgpiod.hash
package/libgpiod/libgpiod.mk

index fcf212ed2aa6b6b2d1ce09a57750802018c8701c..aeeabf6a425e844db08d8cf372918a374e0e59e9 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 de1947f3cb2cc4174364af430309fe6238976658575655bdbd76c60cffa7df92 libgpiod-v0.2.tar.gz
+sha256 24794006c14194e269b944f2cca0e85e481f1538be3c143479c4c6691bf25add libgpiod-v0.3.tar.gz
index c95ea44514df009b2685ceef2383457513d096f7..76648bd7d305e9ab3592c880b0ad7059f38542df 100644 (file)
@@ -4,11 +4,13 @@
 #
 ################################################################################
 
-LIBGPIOD_VERSION = v0.2
+LIBGPIOD_VERSION = v0.3
 LIBGPIOD_SITE = $(call github,brgl,libgpiod,$(LIBGPIOD_VERSION))
 LIBGPIOD_LICENSE = LGPL-2.1+
 LIBGPIOD_LICENSE_FILES = COPYING
 
+LIBGPIOD_DEPENDENCIES = host-pkgconf
+
 # Needed for autoreconf to work properly
 define LIBGPIOD_FIXUP_M4_DIR
         mkdir $(@D)/m4