phytool: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 13 Apr 2017 09:33:20 +0000 (11:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Apr 2017 19:30:33 +0000 (21:30 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/phytool/Config.in [new file with mode: 0644]
package/phytool/phytool.hash [new file with mode: 0644]
package/phytool/phytool.mk [new file with mode: 0644]

index a7e1849bd5e9f2e288fdb20545e2e7b974bf9750..9550094ab58474eca3156f650a55db23048e1a4c 100644 (file)
@@ -1740,6 +1740,7 @@ F:        package/linux-firmware/
 F:     package/modem-manager/
 F:     package/nuttcp/
 F:     package/parted/
+F:     package/phytool/
 F:     package/python*
 F:     package/ser2net/
 F:     package/socketcand/
index 3683578f1ea6f3937d85fdaabd73339f57de74d2..d0e7af1661accfc56b0482858bc89ee903a89f76 100644 (file)
@@ -1640,6 +1640,7 @@ endif
        source "package/openvpn/Config.in"
        source "package/p910nd/Config.in"
        source "package/phidgetwebservice/Config.in"
+       source "package/phytool/Config.in"
        source "package/pound/Config.in"
        source "package/pppd/Config.in"
        source "package/pptp-linux/Config.in"
diff --git a/package/phytool/Config.in b/package/phytool/Config.in
new file mode 100644 (file)
index 0000000..7dca31d
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PHYTOOL
+       bool "phytool"
+       help
+         Linux MDIO register access utility.
+
+         https://github.com/wkz/phytool
diff --git a/package/phytool/phytool.hash b/package/phytool/phytool.hash
new file mode 100644 (file)
index 0000000..37d8f66
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://github.com/wkz/phytool/releases/download/v1.0.1/phytool-1.0.1.tar.xz.md5
+# sha256 locally computed:
+md5  08997ad8f01faf84f3da0638f3ad8b16  phytool-1.0.1.tar.xz
+sha256  b08c538dc8024e542d54742b93cc7748c7062477f060d6e9331a67009aeadd88  phytool-1.0.1.tar.xz
diff --git a/package/phytool/phytool.mk b/package/phytool/phytool.mk
new file mode 100644 (file)
index 0000000..2a47dfa
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# phytool
+#
+################################################################################
+
+PHYTOOL_VERSION = 1.0.1
+PHYTOOL_SOURCE = phytool-$(PHYTOOL_VERSION).tar.xz
+PHYTOOL_SITE = https://github.com/wkz/phytool/releases/download/v$(PHYTOOL_VERSION)
+PHYTOOL_LICENSE = GPL-2.0+
+PHYTOOL_LICENSE_FILES = LICENSE
+
+define PHYTOOL_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               LDLIBS="$(TARGET_LDFLAGS)"
+endef
+
+define PHYTOOL_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               DESTDIR="$(TARGET_DIR)" \
+               PREFIX="usr" install
+endef
+
+$(eval $(generic-package))