Flush configuration cache, needed if config has changed
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 23:01:22 +0000 (23:01 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 23:01:22 +0000 (23:01 -0000)
Makefile

index a55d9bbb992d4f7c7acbbc93a0f8de4542693831..c84a23eaeda8222d19bc2aa852ad0dabf0f260d9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -476,6 +476,9 @@ clean:
 distclean: clean
        rm -rf sources/*
 
+flush:
+       rm -f $(PROJECT_BUILD_DIR)/tgt-config.cache
+
 endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 %_defconfig: $(CONFIG)/conf
@@ -519,6 +522,7 @@ help:
        @echo '  source                 - download all sources needed for offline-build'
        @echo '  source-check           - check all packages for valid download URLs'
        @echo '  external-deps          - list external packages used'
+       @echo '  flush                  - flush configuration cache'
        @echo
        @echo 'See docs/README and docs/buildroot.html for further details'
        @echo