axel: Fix OpenSSL dependency
authorIsmael Luceno <ismael@iodev.co.uk>
Tue, 5 Dec 2017 05:42:36 +0000 (02:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Dec 2017 21:04:18 +0000 (22:04 +0100)
openssl is a virtual package, that can be provided by either libressl
or libopenssl, so there's no need to check for libressl separately.

Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/axel/axel.mk

index dcc8afd0b4a0b1940f0916ac30dbfd89e59fa69e..136c2e26eb087ee4ad7aba10de2ad4fd8bb428ac 100644 (file)
@@ -17,10 +17,7 @@ AXEL_CONF_OPTS = \
        ac_cv_prog_cc_c99=-std=c99 \
        CFLAGS="$(TARGET_CFLAGS)"
 
-ifeq ($(BR2_PACKAGE_LIBRESSL),y)
-AXEL_CONF_OPTS += --with-ssl
-AXEL_DEPENDENCIES += libressl
-else ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
 AXEL_CONF_OPTS += --with-ssl
 AXEL_DEPENDENCIES += openssl
 else