Makefile: simplify target skeleton copying
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Mar 2013 07:33:18 +0000 (08:33 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Mar 2013 07:33:18 +0000 (08:33 +0100)
We already use the .root stamp file to remember if we have copied the
skeleton, so we can remove the /bin check.

Likewise, we should always have a TARGET_SKELETON (or explicitly error
out otherwise), so remove that check as well.

Finally, now that we're using rsync to do the copy, we might as well
use its exclude support instead of cleaning up unwanted files afterwards.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 62311ede36ee9d2cfe5dc59b985f8f6cb278a90c..c95bb1e9213dc0d8d574d5ea26a1e5f5809064ea 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -429,14 +429,9 @@ endif
 
 $(BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
-       if ! [ -d "$(TARGET_DIR)/bin" ]; then \
-               if [ -d "$(TARGET_SKELETON)" ]; then \
-                       rsync -au $(TARGET_SKELETON)/ $(TARGET_DIR)/; \
-               fi; \
-       fi
+       rsync -au --exclude=.empty --exclude=CVS --exclude=.svn --exclude='*~' \
+               $(TARGET_SKELETON)/ $(TARGET_DIR)/
        cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
-       -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
-       -find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
        touch $@
 
 $(TARGET_DIR): $(BUILD_DIR)/.root