package/libsoup: always disable tls_check
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 10 Jun 2021 19:03:13 +0000 (21:03 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 20 Jun 2021 16:33:54 +0000 (18:33 +0200)
Always disable tls_check to avoid the following build failure since bump to
version 2.72.0 in commit 8e5f7f1cfc8fd7a9d5270f6a9707eb9eecfd21da:

../output-1/build/libsoup-2.72.0/meson.build:184:4: ERROR: Can not run test applications in this cross environment.

Indeed, tls_check will run code since
https://gitlab.gnome.org/GNOME/libsoup/-/commit/5c45253243a2deca4880d4f614f2932373445cf9

That is the only thing that this option does: it runs code to check that
libgio is built with TLS support.

While at it, also drop glib-networking build-time dependency

Also mark gnutls as a runtime dependency (it already was used as such).

Fixes:
 - http://autobuild.buildroot.org/results/9e539dc7185cfb81f18438dd36357cb49ef23a5a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libsoup/Config.in
package/libsoup/libsoup.mk

index 0c0454c7c2b056cd405836cc0e1ac5501db548f9..02e8e8b578e7611c77e852523529d5b886f4b28e 100644 (file)
@@ -24,8 +24,8 @@ config BR2_PACKAGE_LIBSOUP_GNOME
 config BR2_PACKAGE_LIBSOUP_SSL
        bool "https support"
        depends on !BR2_STATIC_LIBS # glib-networking, gnutls
-       select BR2_PACKAGE_GLIB_NETWORKING
-       select BR2_PACKAGE_GNUTLS
+       select BR2_PACKAGE_GLIB_NETWORKING # runtime
+       select BR2_PACKAGE_GNUTLS # runtime
        help
          Enable HTTPS (SSL) support.
 
index 2f63e9e85c1c46a99a560441f3c05f735e1ea496..964488f43096cba14dfc00342a093c80ecd2eac4 100644 (file)
@@ -30,6 +30,7 @@ LIBSOUP_CONF_OPTS = \
        -Dntlm=disabled \
        -Dsysprof=disabled \
        -Dtests=false \
+       -Dtls_check=false \
        -Dvapi=disabled
 
 ifeq ($(BR2_PACKAGE_BROTLI),y)
@@ -52,10 +53,4 @@ else
 LIBSOUP_CONF_OPTS += -Dgnome=false
 endif
 
-ifeq ($(BR2_PACKAGE_LIBSOUP_SSL),y)
-LIBSOUP_DEPENDENCIES += glib-networking
-else
-LIBSOUP_CONF_OPTS += -Dtls_check=false
-endif
-
 $(eval $(meson-package))