package/docker-engine: security bump to version 18.09.7
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 28 Jun 2019 06:32:45 +0000 (08:32 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 30 Jun 2019 12:38:27 +0000 (14:38 +0200)
Fixes CVE-2018-15664: API endpoints behind the 'docker cp' command are
vulnerable to a symlink-exchange attack with Directory Traversal, giving
attackers arbitrary read-write access to the host filesystem with root
privileges, because daemon/archive.go does not do archive operations on a
frozen filesystem (or from within a chroot).

And includes additional post-18.09.6 fixes:

Builder
- Fixed a panic error when building dockerfiles that contain only comments.
  moby/moby#38487
- Added a workaround for GCR authentication issue. moby/moby#38246
- Builder-next: Fixed a bug in the GCR token cache implementation
  workaround.  moby/moby#39183

Runtime
- Added performance optimizations in aufs and layer store that helps in
  massively parallel container creation and removal.  moby/moby#39107,
  moby/moby#39135
- daemon: fixed a mirrors validation issue. moby/moby#38991
- Docker no longer supports sorting UID and GID ranges in ID maps.
  moby/moby#39288

Logging
- Added a fix that now allows large log lines for logger plugins.
  moby/moby#39038

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/docker-engine/docker-engine.hash
package/docker-engine/docker-engine.mk

index 5beceea04bfc623dd8644f46a7924c66888643ad..4ef6905b5dc0610efc1666427ab5c81fd8e9b49f 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 7cb45266fff79245c81ec86c455d4b0513ca5d4ec1b9be8c8330df30a9467481  docker-engine-18.09.6.tar.gz
+sha256 b4f55831f5e7c5a92cd91f77aad1541ccd572eb18df2f44a01c372bceb3f9b6b  docker-engine-18.09.7.tar.gz
 sha256 2d81ea060825006fc8f3fe28aa5dc0ffeb80faf325b612c955229157b8c10dc0  LICENSE
index dd23c59d163dce213972b5621c4cd307aea1c992..99e3088f65e926945895f960138c3ded9a84648f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-DOCKER_ENGINE_VERSION = 18.09.6
+DOCKER_ENGINE_VERSION = 18.09.7
 DOCKER_ENGINE_SITE = $(call github,docker,engine,v$(DOCKER_ENGINE_VERSION))
 
 DOCKER_ENGINE_LICENSE = Apache-2.0