uboot: add option to depend on host-lzop
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Jul 2018 20:11:52 +0000 (22:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Aug 2018 14:23:05 +0000 (16:23 +0200)
Some U-Boot configurations use lzop, which may not be available on the
build machine since it's not a mandatory dependency of Buildroot.

To solve this, a new option BR2_TARGET_UBOOT_NEEDS_LZOP is introduced,
and handled in a similar way to the existing
BR2_TARGET_UBOOT_NEEDS_OPENSSL option.

This fixes the build of the dra7xx_evm U-Boot defconfig as of U-Boot
2018.07, on a build machine without lzop installed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 8e369cec04f03f5a7cef8bd52620d1e2cb4eab80..9e40c11fa1afc90ae57bf97db095348a4648d6c0 100644 (file)
@@ -159,6 +159,14 @@ config BR2_TARGET_UBOOT_NEEDS_OPENSSL
          typically the case when the board configuration has
          CONFIG_FIT_SIGNATURE enabled.
 
+config BR2_TARGET_UBOOT_NEEDS_LZOP
+       bool "U-Boot needs lzop"
+       help
+         Select this option if your U-Boot board configuration
+         requires lzop to be available on the host. This is typically
+         the case when the board configuration has CONFIG_SPL_LZO
+         enabled.
+
 config BR2_TARGET_UBOOT_NEEDS_ATF_BL31
        bool "U-Boot needs ATF BL31"
        depends on BR2_TARGET_ARM_TRUSTED_FIRMWARE
index 04c759be3438fdfa90762c21cfdf5e82292fc46a..3e05f3804633bc5956752418b3d019dc0573cf7a 100644 (file)
@@ -152,6 +152,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
 UBOOT_DEPENDENCIES += host-openssl
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_LZOP),y)
+UBOOT_DEPENDENCIES += host-lzop
+endif
+
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE