hostapd: Install default hostapd.conf on target
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Thu, 7 Jul 2016 06:12:26 +0000 (09:12 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Jul 2016 09:48:51 +0000 (11:48 +0200)
For convenience it's nice to have default hostapd.conf installed
on target automatically as a good starting point.

Otherwise user has to create it manually from scratch.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>i
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/hostapd/hostapd.mk

index dca07c1bc58494c906f28a99ade55ae2f84e885f..5aa2b9a9e8a5cd8d1aec5401d42f013177d05ab4 100644 (file)
@@ -86,6 +86,8 @@ define HOSTAPD_INSTALL_TARGET_CMDS
                $(TARGET_DIR)/usr/sbin/hostapd
        $(INSTALL) -m 0755 -D $(@D)/$(HOSTAPD_SUBDIR)/hostapd_cli \
                $(TARGET_DIR)/usr/bin/hostapd_cli
+       $(INSTALL) -m 0644 -D $(@D)/$(HOSTAPD_SUBDIR)/hostapd.conf \
+               $(TARGET_DIR)/etc/hostapd.conf
 endef
 
 $(eval $(generic-package))