package/i2c-tools: bump to version 3.1.2
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Thu, 18 Jun 2015 08:12:28 +0000 (10:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 Jun 2015 21:29:57 +0000 (23:29 +0200)
This patch bumps version to 3.1.2 and adds support for the recently
introduced python3 support for py-smbus.

Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/i2c-tools/i2c-tools.hash
package/i2c-tools/i2c-tools.mk

index a6c376f101dc3219fc109d455c9aeef673975b55..c12ffe845bd971ea9a4dbbac8b3e270f3f11b073 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed hash
-sha256 14d4d7d60d1c12e43f2befe239c682a5c44c27682f153d4b58c1e392d2db1700  i2c-tools-3.1.1.tar.bz2
+sha256 db5e69f2e2a6e3aa2ecdfe6a5f490b149c504468770f58921c8c5b8a7860a441  i2c-tools-3.1.2.tar.bz2
index 6c156ca421344f2f2600777475be7d0e192f67b2..187bd09754e95b7881b6daf094d83ba8856f3d3a 100644 (file)
@@ -4,16 +4,23 @@
 #
 ################################################################################
 
-I2C_TOOLS_VERSION = 3.1.1
+I2C_TOOLS_VERSION = 3.1.2
 I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
 I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
 I2C_TOOLS_LICENSE = GPLv2+, GPLv2 (py-smbus)
 I2C_TOOLS_LICENSE_FILES = COPYING
 
-# Build/install steps mirror the distutil python package type in the python package
-# infrastructure
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 I2C_TOOLS_DEPENDENCIES += python
+endif
+
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
+I2C_TOOLS_DEPENDENCIES += python3
+endif
+
+# Build/install steps mirror the distutil python package type in the python package
+# infrastructure
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 # BASE_ENV taken from PKG_PYTHON_DISTUTILS_ENV in package/pkg-python.mk
 I2C_TOOLS_PYTHON_BASE_ENV = \
        $(PKG_PYTHON_DISTUTILS_ENV) \