Eliminate $(HOST_DIR)/usr
authorArnout Vandecappelle <arnout@mind.be>
Tue, 4 Jul 2017 14:03:53 +0000 (16:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 09:45:35 +0000 (11:45 +0200)
We currently use $(HOST_DIR)/usr as the prefix for host packages. That
has a few disadvantages:

- There are some things installed in $(HOST_DIR)/etc and
  $(HOST_DIR)/sbin, which is inconsistent.

- To pack a buildroot-built toolchain into a tarball for use as an
  external toolchain, you have to pack output/host/usr instead of the
  more obvious output/host.

- Because of the above, the internal toolchain wrapper breaks which
  forces us to work around it (call the actual toolchain executable
  directly). This is OK for us, but when used in another build system,
  that's a problem.

- Paths are four characters longer.

To allow us to gradually eliminate $(HOST_DIR)/usr while building
packages, replace it with a symlink to .

The symlinks from $(HOST_DIR)/usr/$(GNU_TARGET_NAME) and
$(HOST_DIR)/usr/lib that were added previously are removed again.

Note that the symlink creation will break when $(HOST_DIR)/usr
already exists as a directory, i.e. when rebuilding in an existing
output directory. This is necessary: if we don't break it now, the
following commits (which remove the usr part from various variables)
_will_ break it.

At the same time as creating this symlink, we have to update the
external toolchain wrapper and the external toolchain symlinks to go
one directory less up. Indeed, $(HOST_DIR) is one level less up than
it was before.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
toolchain/toolchain-external/pkg-toolchain-external.mk
toolchain/toolchain-wrapper.c

index ac349a79e88a2adc74ea6e1aaed0c820a3b2e6a4..7453bfd1932879e9cf127576529c0e4343a70a12 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -552,16 +552,15 @@ prepare: $(BUILD_DIR)/buildroot-config/auto.conf
 .PHONY: world
 world: target-post-image
 
-# When creating HOST_DIR, also symlink usr/lib -> ../lib
+# When creating HOST_DIR, also symlink usr -> .
 $(HOST_DIR):
-       @mkdir -p $@/usr $@/lib
-       @ln -snf ../lib $@/usr/lib
+       @mkdir -p $@
+       @ln -snf . $@/usr
 
 # Populating the staging with the base directories is handled by the skeleton package
 $(STAGING_DIR): | $(HOST_DIR)
        @mkdir -p $(STAGING_DIR)
        @ln -snf $(STAGING_DIR) $(BASE_DIR)/staging
-       @ln -snf ../$(GNU_TARGET_NAME) $(HOST_DIR)/usr/$(GNU_TARGET_NAME)
 
 RSYNC_VCS_EXCLUSIONS = \
        --exclude .svn --exclude .git --exclude .hg --exclude .bzr \
index 8460e37d095f8dd98270e29b5b37339d4ac84ffe..adbd3fe67e15690ba611c8cf689936ea40bd651e 100644 (file)
@@ -250,18 +250,18 @@ define TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER
                base=$${i##*/}; \
                case "$$base" in \
                *-ar|*-ranlib|*-nm) \
-                       ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%../..%') .; \
+                       ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%..%') .; \
                        ;; \
                *cc|*cc-*|*++|*++-*|*cpp|*-gfortran) \
                        ln -sf toolchain-wrapper $$base; \
                        ;; \
                *gdb|*gdbtui) \
                        if test "$(BR2_PACKAGE_HOST_GDB)" != "y"; then \
-                               ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%../..%') .; \
+                               ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%..%') .; \
                        fi \
                        ;; \
                *) \
-                       ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%../..%') .; \
+                       ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%..%') .; \
                        ;; \
                esac; \
        done
index 100aa181c6805d3161d321c1ae2a937d522b9530..3a4455ff829d6eba1daff1f299f0158eadfabafa 100644 (file)
@@ -178,7 +178,7 @@ int main(int argc, char **argv)
                        perror(__FILE__ ": malloc");
                        return 2;
                }
-               sprintf(relbasedir, "%s/../..", argv[0]);
+               sprintf(relbasedir, "%s/..", argv[0]);
                absbasedir = realpath(relbasedir, NULL);
        } else {
                basename = progpath;