libshout: add optional openssl support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 31 Aug 2016 22:05:50 +0000 (00:05 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 31 Aug 2016 22:18:27 +0000 (00:18 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libshout/libshout.mk

index 7c07909d3ee589f581a6541270de48e3e20ee48a..bf85595204648e57f8f7dc580b7df2707ef8ae8d 100644 (file)
@@ -28,4 +28,11 @@ else
 LIBSHOUT_CONF_OPTS += --disable-speex
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBSHOUT_CONF_OPTS += --with-openssl
+LIBSHOUT_DEPENDENCIES += openssl
+else
+LIBSHOUT_CONF_OPTS += --without-openssl
+endif
+
 $(eval $(autotools-package))