opengl: correct detection of virtual packages having no dependencies
authorWill Wagner <will_wagner@carallon.com>
Thu, 30 May 2013 13:08:05 +0000 (14:08 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 13:42:45 +0000 (15:42 +0200)
I believe the original intent was to make it that the configure step
for the opengl virtual packages fails if there is not at least one
dependency. This patch fixes the logic so that it actually fails if
dependency list is empty

Signed-off-by: Will Wagner <will_wagner@carallon.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/opengl/libegl/libegl.mk
package/opengl/libgles/libgles.mk
package/opengl/libopenvg/libopenvg.mk

index c4954963c8e99efc268aa31179085d750c85dfe8..8ff24e886a4fc85186057d3da81107b1f8d8400f 100644 (file)
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 LIBEGL_DEPENDENCIES += rpi-userland
 endif
 
-ifeq ($(LIBEGL_DEPENDENCIES),y)
+ifeq ($(LIBEGL_DEPENDENCIES),)
 define LIBEGL_CONFIGURE_CMDS
        echo "No libEGL implementation selected. Configuration error."
        exit 1
index f0d0eec9c375d6bf77bec5fc752adab6b613d1f0..675d11fd35b07a02beec67b63f9cdd6deb4c3a94 100644 (file)
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 LIBGLES_DEPENDENCIES += rpi-userland
 endif
 
-ifeq ($(LIBGLES_DEPENDENCIES),y)
+ifeq ($(LIBGLES_DEPENDENCIES),)
 define LIBGLES_CONFIGURE_CMDS
        echo "No libGLES implementation selected. Configuration error."
        exit 1
index 573fa786dd2a9e6dbc8f118a77e2bdeec00ff2af..746b52c9a9d57cf3466f0195e99d55637faf81b2 100644 (file)
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 LIBOPENVG_DEPENDENCIES += rpi-userland
 endif
 
-ifeq ($(LIBOPENVG_DEPENDENCIES),y)
+ifeq ($(LIBOPENVG_DEPENDENCIES),)
 define LIBOPENVG_CONFIGURE_CMDS
        echo "No libOpenVG implementation selected. Configuration error."
        exit 1