Add a parallel compilation fix for fontconfig
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Nov 2008 19:38:10 +0000 (19:38 -0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Nov 2008 19:38:10 +0000 (19:38 -0000)
This patch adds a patch to fix bug
https://bugs.freedesktop.org/show_bug.cgi?id=16464 affecting parallel
compilation of fontconfig.

The patch is the one proposed in the bugzilla entry, available at
https://bugs.freedesktop.org/attachment.cgi?id=17294.

Without this patch, the compilation (at BR2_JLEVEL > 1) of fontconfig
sometimes fails with:

In file included from fc-case.c:25:
../src/fcint.h:118:21: error: fcalias.h: No such file or directory

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch [new file with mode: 0644]
package/fontconfig/fontconfig.mk

diff --git a/package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch b/package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch
new file mode 100644 (file)
index 0000000..56623cf
--- /dev/null
@@ -0,0 +1,26 @@
+---
+ fc-case/Makefile.am |    4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+Index: fontconfig-2.6.0/fc-case/Makefile.am
+===================================================================
+--- fontconfig-2.6.0.orig/fc-case/Makefile.am
++++ fontconfig-2.6.0/fc-case/Makefile.am
+@@ -36,6 +36,8 @@
+ noinst_MANS=fc-case.man
++noinst_HEADERS=$(TARG)
++
+ fc_case_SRCS= \
+       fc-case.c \
+       fccaseint.h \
+@@ -52,7 +54,7 @@
+ ALIAS_FILES = fcalias.h fcaliastail.h
+-BUILT_SOURCES = $(ALIAS_FILES) $(TARG)
++BUILT_SOURCES = $(ALIAS_FILES)
+ $(ALIAS_FILES): 
+       touch $(ALIAS_FILES)
index 4ed9985b6321fef27473e8bef3eb97b5f63f86d7..8e5577aa8cc6f0ae33095f7852ee55eef31121c4 100644 (file)
@@ -6,7 +6,7 @@
 FONTCONFIG_VERSION = 2.6.0
 FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.gz
 FONTCONFIG_SITE = http://fontconfig.org/release
-FONTCONFIG_AUTORECONF = NO
+FONTCONFIG_AUTORECONF = YES
 FONTCONFIG_INSTALL_STAGING = YES
 FONTCONFIG_INSTALL_TARGET = YES