package/coreutils: rename COREUTILS_CLEANUP_BIN to a more sensible name
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 20 Jun 2019 18:34:21 +0000 (20:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 20 Jun 2019 18:57:11 +0000 (20:57 +0200)
COREUTILS_CLEANUP_BIN doesn't mean much, what it really does is fixing
the location of binaries, so let's rename to a more sensible name.

This is done in preparation to the introduction of support for
building coreutils as individual binaries.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/coreutils/coreutils.mk

index 8e5518f6383e5c1fba13c40b33b3cd1f90cbe127..5e7e0c6ea0939ee6c157263da485c347f1852223 100644 (file)
@@ -96,14 +96,14 @@ COREUTILS_DEPENDENCIES += openssl
 endif
 
 ifeq ($(BR2_ROOTFS_MERGED_USR),)
-define COREUTILS_CLEANUP_BIN
+define COREUTILS_FIX_BIN_LOCATION
        # some things go in /bin rather than /usr/bin
        $(foreach f,$(COREUTILS_BIN_PROGS), \
                rm -f $(TARGET_DIR)/usr/bin/$(f) && \
                ln -sf ../usr/bin/coreutils $(TARGET_DIR)/bin/$(f)
        )
 endef
-COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_CLEANUP_BIN
+COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_FIX_BIN_LOCATION
 endif
 
 ifeq ($(BR2_STATIC_LIBS),y)