packages: rename FOO_KCONFIG_OPT into FOO_KCONFIG_OPTS
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sat, 27 Sep 2014 19:32:47 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Oct 2014 16:54:54 +0000 (18:54 +0200)
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS,
make the same change for FOO_KCONFIG_OPT.

Sed command used:
   find * -type f | xargs sed -i 's#_KCONFIG_OPT\>#&S#g'

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-kconfig.txt
package/busybox/busybox.mk
package/pkg-kconfig.mk
package/uclibc/uclibc.mk

index 979a2b5f5e1917afd9df4ed44a167f485bafd8cb..e87d3930704351bf9d32391cb9dee78268bd3017 100644 (file)
@@ -46,7 +46,7 @@ be set to suit the needs of the package under consideration:
 * +FOO_KCONFIG_EDITORS+: a space-separated list of kconfig editors to
   support, for example 'menuconfig xconfig'. By default, 'menuconfig'.
 
-* +FOO_KCONFIG_OPT+: extra options to pass when calling the kconfig
+* +FOO_KCONFIG_OPTS+: extra options to pass when calling the kconfig
   editors. This may need to include '$(FOO_MAKE_OPTS)', for example. By
   default, empty.
 
index c74873210d91341daf2470e43a85ed328a19791c..73a99fb27ac03e64e34f5f6b8af492415b9e5c84 100644 (file)
@@ -47,7 +47,7 @@ endif
 
 BUSYBOX_KCONFIG_FILE = $(BUSYBOX_CONFIG_FILE)
 BUSYBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig
-BUSYBOX_KCONFIG_OPT = $(BUSYBOX_MAKE_OPTS)
+BUSYBOX_KCONFIG_OPTS = $(BUSYBOX_MAKE_OPTS)
 
 define BUSYBOX_PERMISSIONS
 /bin/busybox                    f 4755 0 0 - - - - -
index cd08c1ab98e4a4b789a73d54da557a4c41628e5c..071153a0bfc33b8f41f18df4006a53d60863068a 100644 (file)
@@ -33,7 +33,7 @@ $(call inner-generic-package,$(1),$(2),$(3),$(4))
 
 # Default values
 $(2)_KCONFIG_EDITORS ?= menuconfig
-$(2)_KCONFIG_OPT ?=
+$(2)_KCONFIG_OPTS ?=
 $(2)_KCONFIG_FIXUP_CMDS ?=
 
 # FOO_KCONFIG_FILE is required
@@ -51,7 +51,7 @@ $$($(2)_DIR)/.config: $$($(2)_KCONFIG_FILE) | $(1)-patch
 $$($(2)_DIR)/.stamp_kconfig_fixup_done: $$($(2)_DIR)/.config
        $$($(2)_KCONFIG_FIXUP_CMDS)
        @yes "" | $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
-               $$($(2)_KCONFIG_OPT) oldconfig
+               $$($(2)_KCONFIG_OPTS) oldconfig
        $$(Q)touch $$@
 
 # Before running configure, the configuration file should be present and fixed
@@ -60,7 +60,7 @@ $$($(2)_TARGET_CONFIGURE): $$($(2)_DIR)/.stamp_kconfig_fixup_done
 # Configuration editors (menuconfig, ...)
 $$(addprefix $(1)-,$$($(2)_KCONFIG_EDITORS)): $$($(2)_DIR)/.stamp_kconfig_fixup_done
        $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
-               $$($(2)_KCONFIG_OPT) $$(subst $(1)-,,$$@)
+               $$($(2)_KCONFIG_OPTS) $$(subst $(1)-,,$$@)
        rm -f $$($(2)_DIR)/.stamp_{kconfig_fixup_done,configured,built}
        rm -f $$($(2)_DIR)/.stamp_{target,staging}_installed
 
index 59339736555a9fb324aa59a7aaec903c58ab4a78..1469f8dff76af0af945daaf838e681c25ea95882 100644 (file)
@@ -39,7 +39,7 @@ endif
 
 UCLIBC_KCONFIG_FILE = $(UCLIBC_CONFIG_FILE)
 
-UCLIBC_KCONFIG_OPT = \
+UCLIBC_KCONFIG_OPTS = \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX=$(STAGING_DIR) \
                DEVEL_PREFIX=/usr/ \