package/ucl: fix build with host gcc 6.x
authorMartin Bark <martin@barkynet.com>
Thu, 16 Jun 2016 16:00:49 +0000 (17:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 14:16:45 +0000 (16:16 +0200)
ucl fails with the following error when using gcc 6.x on the host:

 checking whether your compiler passes the ACC conformance test... FAILED
 configure:
 configure: Your compiler failed the ACC conformance test - for details see
 configure: `config.log'. Please check that log file and consider sending
 configure: a patch or bug-report to <markus@oberhumer.com>.
 configure: Thanks for your support.
 configure:
 configure: error: ACC conformance test failed. Stop.

Fix the issue by using the ISO C90 standard.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ucl/ucl.mk

index 2654a5a7ca8a4091468dc1896d42d35701c5ec65..e4dc1b3eda2f92a81e458fec1080a1791016020d 100644 (file)
@@ -9,4 +9,7 @@ UCL_SITE = http://www.oberhumer.com/opensource/ucl/download
 UCL_LICENSE = GPLv2+
 UCL_LICENSE_FILES = COPYING
 
+# Fix ACC conformance test failure for host gcc 6.x
+HOST_UCL_CONF_ENV += CPPFLAGS="$(HOST_CPPFLAGS) -std=c90"
+
 $(eval $(host-autotools-package))