psmisc: bump to version 22.13
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 7 Jan 2011 18:05:27 +0000 (15:05 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Jan 2011 19:45:55 +0000 (20:45 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/psmisc/psmisc-no-__progname.patch
package/psmisc/psmisc.mk

index 82e6daf77b4a949e1b6a4e19cb0929354cbdc82d..063b120eef7a1de8cb4597beb42e0a889499d45e 100644 (file)
@@ -4,21 +4,27 @@ uclibc (per default) doesn't implement __progname, and the pstree.x11
 stuff isn't that critical, so just disable it.
 
 Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- src/pstree.c |    3 ---
- 1 file changed, 3 deletions(-)
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 
-Index: psmisc-22.8/src/pstree.c
-===================================================================
---- psmisc-22.8.orig/src/pstree.c
-+++ psmisc-22.8/src/pstree.c
-@@ -893,9 +893,6 @@ main (int argc, char **argv)
-   bindtextdomain(PACKAGE, LOCALEDIR);
-   textdomain(PACKAGE);
+diff -Nura psmisc-22.13.orig/src/pstree.c psmisc-22.13/src/pstree.c
+--- psmisc-22.13.orig/src/pstree.c     2010-07-12 08:10:03.000000000 -0300
++++ psmisc-22.13/src/pstree.c  2011-01-07 15:02:41.902741728 -0300
+@@ -49,8 +49,6 @@
+ #include <selinux/selinux.h>
+ #endif                                /*WITH_SELINUX */
+-extern const char *__progname;
+-
+ #define PROC_BASE    "/proc"
+ /* UTF-8 defines by Johan Myreen, updated by Ben Winslow */
+@@ -854,9 +852,6 @@
+     textdomain(PACKAGE);
  #endif
--  
--  if (!strcmp(__progname, "pstree.x11"))
--    wait_end=1;
  
-   /*
-    * Attempt to figure out a good default symbol set.  Will be overriden by
+-    if (!strcmp(__progname, "pstree.x11"))
+-        wait_end = 1;
+-
+     /*
+      * Attempt to figure out a good default symbol set.  Will be overriden by
+      * command-line options, if given.
index e4301da984ee91bf211ac2a2d8337a5b423b7249..3cbf9418e81a8082e57676c7598c2a4480c997b0 100644 (file)
@@ -3,10 +3,14 @@
 # psmisc
 #
 #############################################################
-PSMISC_VERSION:=22.8
-PSMISC_SOURCE:=psmisc-$(PSMISC_VERSION).tar.gz
-PSMISC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/psmisc
-PSMISC_AUTORECONF:=NO
-PSMISC_DEPENDENCIES:=ncurses $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
+
+PSMISC_VERSION = 22.13
+PSMISC_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/psmisc
+PSMISC_DEPENDENCIES = ncurses $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
+
+# build after busybox, we prefer fat versions while we're at it
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+PSMISC_DEPENDENCIES += busybox
+endif
 
 $(eval $(call AUTOTARGETS,package,psmisc))