uboot: bump to version 2017.07
authorJörg Krause <joerg.krause@embedded.rocks>
Wed, 12 Jul 2017 19:29:03 +0000 (21:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 21 Jul 2017 20:43:36 +0000 (22:43 +0200)
Add a new config option BR2_TARGET_UBOOT_NEEDS_PYLIBFDT for U-Boot
targets, like sunxi, needing the Python libfdt library.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
[Thomas: drop bogus selects on BR2_PACKAGE_HOST_{PYTHON,SWIG}.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/Config.in
boot/uboot/uboot.hash
boot/uboot/uboot.mk

index 52f3a326c6fafe41c3899d501535cfce87f7075c..2ae38e95d5af9eba8a41a141f3584357fdc4444a 100644 (file)
@@ -38,7 +38,7 @@ choice
          Select the specific U-Boot version you want to use
 
 config BR2_TARGET_UBOOT_LATEST_VERSION
-       bool "2017.05"
+       bool "2017.07"
 
 config BR2_TARGET_UBOOT_CUSTOM_VERSION
        bool "Custom version"
@@ -86,7 +86,7 @@ endif
 
 config BR2_TARGET_UBOOT_VERSION
        string
-       default "2017.05"       if BR2_TARGET_UBOOT_LATEST_VERSION
+       default "2017.07"       if BR2_TARGET_UBOOT_LATEST_VERSION
        default BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE \
                if BR2_TARGET_UBOOT_CUSTOM_VERSION
        default "custom"        if BR2_TARGET_UBOOT_CUSTOM_TARBALL
@@ -138,6 +138,12 @@ config BR2_TARGET_UBOOT_NEEDS_DTC
          Select this option if your U-Boot board configuration
          requires the Device Tree compiler to be available.
 
+config BR2_TARGET_UBOOT_NEEDS_PYLIBFDT
+       bool "U-Boot needs pylibfdt"
+       help
+         Select this option if your U-Boot board configuration
+         requires the Python libfdt library to be available.
+
 config BR2_TARGET_UBOOT_NEEDS_OPENSSL
        bool "U-Boot needs OpenSSL"
        help
index e11d92ff153419352cf3a35bcb661d1a46b0c753..3ba8e34ba038f89d293c2be11165e5b17a61444c 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256  c8373949d7f0de1059e507b83a655d4cea539f75dc66ccdbb27adbd38d83095e  u-boot-2017.05.tar.bz2
+sha256  5374bfdc8acb9a38c025371b1ff20f45e7533668e84e685d0df5d9e7c0e4feff  u-boot-2017.07.tar.bz2
index 73d72630b23a6dae5f6bd29874d3359fe86d159b..14a8cc949a335e9e44aeeb5c3d746d061ad4e9fc 100644 (file)
@@ -138,6 +138,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
 UBOOT_DEPENDENCIES += host-dtc
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
+UBOOT_DEPENDENCIES += host-python host-swig
+endif
+
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
 UBOOT_DEPENDENCIES += host-openssl
 endif