package/matchbox: enable support for the Xsession manager
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:40 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 21:06:29 +0000 (23:06 +0200)
Since this is a non-obvious dependency, just select the appropriate
library.

Also, add a comment to act as a separator between matchbox' options
and the other matchbox packages.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/Config.in
package/matchbox/matchbox.mk

index ae33ecfc2c1ac14b021ec804ed5002e1cdf5872d..d42b90fbf7caa393a7ba0d4c9077d879ad78b9fe 100644 (file)
@@ -17,6 +17,14 @@ menuconfig BR2_PACKAGE_MATCHBOX
 
 if BR2_PACKAGE_MATCHBOX
 
+config BR2_PACKAGE_MATCHBOX_SM
+       bool "session manager"
+       select BR2_PACKAGE_XLIB_LIBSM
+       help
+         Enable support for the Session Manager.
+
+comment "matchbox utilities"
+
 source "package/matchbox-common/Config.in"
 source "package/matchbox-desktop/Config.in"
 source "package/matchbox-fakekey/Config.in"
index 43f6b4b1df57af53afe8ab6a93e2f2bbaf3f1e73..b1f96a6e5a223bf968c9837b54aea9cc67ac3c75 100644 (file)
@@ -27,4 +27,11 @@ else
 MATCHBOX_CONF_OPTS += --disable-startup-notification
 endif
 
+ifeq ($(BR2_PACKAGE_MATCHBOX_SM),y)
+MATCHBOX_CONF_OPTS += --enable-session
+MATCHBOX_DEPENDENCIES += xlib_libSM
+else
+MATCHBOX_CONF_OPTS += --disable-session
+endif
+
 $(eval $(autotools-package))