linux: fix linux-% shortcut targets
authorBjørn Forsman <bjorn.forsman@gmail.com>
Sun, 19 Dec 2010 18:37:29 +0000 (19:37 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 19 Dec 2010 20:16:37 +0000 (21:16 +0100)
linux-% shortcut targets (short for linux26-%) ignores the ouput dir
$(O) so that 'make O=output.arm linux-menuconfig' is actually run in the
default $(O) directory output/ and not in output.arm/. Fix by passing on
$(O) if set.

[Peter: Use EXTRAMAKEARGS]
Signed-off-by: Bjørn Forsman <bjorn.forsman@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 6636a35785d9062fa9db17bfd94093b91281f80b..f2c6fd51286fe3ee373ccf90895ea2b4ced5e02c 100644 (file)
@@ -200,4 +200,4 @@ endif
 endif
 
 linux-%:
-       $(MAKE) $(subst linux-,linux26-,$@)
+       $(MAKE) $(EXTRAMAKEARGS) $(subst linux-,linux26-,$@)