package/dovecot: add optional support for libsodium
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 31 Mar 2018 16:34:58 +0000 (18:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Mar 2018 18:46:14 +0000 (20:46 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dovecot/dovecot.mk

index 8e775be5f782f7f0f3b889098cbd49963e20e5b6..1a10b30e1610fd1105c8f0fbcb7b3ab79b38b00f 100644 (file)
@@ -57,6 +57,13 @@ else
 DOVECOT_CONF_OPTS += --without-libcap
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
+DOVECOT_CONF_OPTS += --with-sodium
+DOVECOT_DEPENDENCIES += libsodium
+else
+DOVECOT_CONF_OPTS += --without-sodium
+endif
+
 ifeq ($(BR2_PACKAGE_DOVECOT_MYSQL),y)
 DOVECOT_CONF_ENV += MYSQL_CONFIG="$(STAGING_DIR)/usr/bin/mysql_config"
 DOVECOT_CONF_OPTS += --with-mysql