toolchain: enable microblaze toolchain
authorSpenser Gilliland <spenser@gillilanding.com>
Thu, 5 Dec 2013 17:20:56 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:46:44 +0000 (22:46 +0100)
This commit allows to build an internal toolchain for the Microblaze
architecture, with either glibc or eglibc.

Note that we add an explicit list of architectures that are supported
by uClibc, and Microblaze is not part of them, because it currently
doesn't build for this architecture.

[Thomas: add better commit log, add architecture dependencies on
uClibc, to avoid selecting uClibc on Microblaze]

Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/Config.in
toolchain/toolchain-buildroot/Config.in

index 3980d790a48bc2c2e3282d7381a8e5087c63f414..bbfd367a48bc13d26a5e3797d5b1f5e432247cc4 100644 (file)
@@ -35,7 +35,7 @@ choice
 
 config BR2_TOOLCHAIN_BUILDROOT
        bool "Buildroot toolchain"
-       depends on !BR2_microblaze && !BR2_aarch64 && !BR2_nios2
+       depends on !BR2_aarch64 && !BR2_nios2
        select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
 
 config BR2_TOOLCHAIN_EXTERNAL
index 94df0ffab445f542be5b370e293050e307679016..cd88889c4ae383c21fe7992db112cd05c7629a4e 100644 (file)
@@ -10,6 +10,11 @@ choice
 config BR2_TOOLCHAIN_BUILDROOT_UCLIBC
        bool "uClibc"
        select BR2_TOOLCHAIN_USES_UCLIBC
+       depends on BR2_arcle   || BR2_arceb  || BR2_arm    || BR2_armeb    || \
+                  BR2_avr32   || BR2_bfin   || BR2_i386   || BR2_m68k     || \
+                  BR2_mips    || BR2_mipsel || BR2_mips64 || BR2_mips64el || \
+                  BR2_powerpc || BR2_sh     || BR2_sparc  || BR2_xtensa   || \
+                  BR2_x86_64
        help
          This option selects uClibc as the C library for the
          cross-compilation toolchain.
@@ -22,7 +27,7 @@ config BR2_TOOLCHAIN_BUILDROOT_EGLIBC
                   BR2_i386   || BR2_mips     || BR2_mipsel  || \
                   BR2_mips64 || BR2_mips64el || BR2_powerpc || \
                   BR2_sh     || BR2_sh64     || BR2_sparc   || \
-                  BR2_x86_64
+                  BR2_x86_64 || BR2_microblaze
        depends on BR2_USE_MMU
        depends on !BR2_PREFER_STATIC_LIB
        select BR2_TOOLCHAIN_USES_GLIBC
@@ -40,7 +45,7 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
                   BR2_i386   || BR2_mips     || BR2_mipsel  || \
                   BR2_mips64 || BR2_mips64el || BR2_powerpc || \
                   BR2_sh     || BR2_sh64     || BR2_sparc   || \
-                  BR2_x86_64
+                  BR2_x86_64 || BR2_microblaze
        select BR2_TOOLCHAIN_USES_GLIBC
        depends on !BR2_PREFER_STATIC_LIB
        # our glibc.mk enables RPC support