package/elixir: new package
authorFrank Vanbever <frank.vanbever@essensium.com>
Tue, 4 Feb 2020 10:07:32 +0000 (11:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 5 Feb 2020 14:37:51 +0000 (15:37 +0100)
elixir is required to build RabbitMQ starting from v3.7

Signed-off-by: Frank Vanbever <frank.vanbever@essensium.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/elixir/elixir.hash [new file with mode: 0644]
package/elixir/elixir.mk [new file with mode: 0644]

index af03992cc3b206e7d7a82f43bc53df81117c8ec8..67cce2f8e47906741975ac73c9b512c31c8b83d8 100644 (file)
@@ -960,6 +960,7 @@ F:  package/upx/
 F:     package/zxing-cpp/
 
 N:     Frank Vanbever <frank.vanbever@essensium.com>
+F:     package/elixir/
 F:     package/libmodsecurity/
 F:     package/nginx-modsecurity/
 
diff --git a/package/elixir/elixir.hash b/package/elixir/elixir.hash
new file mode 100644 (file)
index 0000000..b4d2f8b
--- /dev/null
@@ -0,0 +1,3 @@
+# Computed locally
+sha256 f3465d8a8e386f3e74831bf9594ee39e6dfde6aa430fe9260844cfe46aa10139  elixir-1.9.4.tar.gz
+sha256 a6cba85bc92e0cff7a450b1d873c0eaa2e9fc96bf472df0247a26bec77bf3ff9  LICENSE
diff --git a/package/elixir/elixir.mk b/package/elixir/elixir.mk
new file mode 100644 (file)
index 0000000..7a545d4
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# elixir
+#
+################################################################################
+
+ELIXIR_VERSION = 1.9.4
+ELIXIR_SITE = $(call github,elixir-lang,elixir,v$(ELIXIR_VERSION))
+ELIXIR_LICENSE = Apache-2.0
+ELIXIR_LICENSE_FILES = LICENSE
+ELIXIR_DEPENDENCIES = host-erlang
+
+define HOST_ELIXIR_BUILD_CMDS
+       $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) compile
+endef
+
+define HOST_ELIXIR_INSTALL_CMDS
+       $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) PREFIX="$(HOST_DIR)" -C $(@D) install
+endef
+
+$(eval $(host-generic-package))