package/efl: enable systemd support
authorRomain Naour <romain.naour@gmail.com>
Fri, 22 Jul 2016 22:23:17 +0000 (00:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 13:09:30 +0000 (15:09 +0200)
systemd it one of the "highly recommended" dependecies according to the
README [1] but disabling it doesn't need the
--enable-i-really-know-what-i-am-doing... option.

That's why BR2_PACKAGE_EFL_HAS_RECOMMENDED_CONFIG is not disabled when
systemd is not selected.

[1] https://git.enlightenment.org/core/efl.git/tree/README?h=efl-1.17#n489

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/efl.mk

index 18d409b51ec279d48f17716f12327084a9640178..d404e71e95e3c91915dd32d04a7047b15df19155 100644 (file)
@@ -25,7 +25,6 @@ EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
 # Configure options:
 # --disable-lua-old: build elua for the target.
 # --disable-sdl: disable sdl2 support.
-# --disable-systemd: disable systemd support.
 # --disable-xinput22: disable X11 XInput v2.2+ support.
 # --with-opengl=none: disable opengl support.
 EFL_CONF_OPTS = \
@@ -34,7 +33,6 @@ EFL_CONF_OPTS = \
        --with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
        --disable-lua-old \
        --disable-sdl \
-       --disable-systemd \
        --disable-xinput22 \
        --with-opengl=none
 
@@ -57,6 +55,13 @@ else
 EFL_CONF_OPTS += --disable-libmount
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+EFL_CONF_OPTS += --enable-systemd
+EFL_DEPENDENCIES += systemd
+else
+EFL_CONF_OPTS += --disable-systemd
+endif
+
 ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
 EFL_CONF_OPTS += --enable-fontconfig
 EFL_DEPENDENCIES += fontconfig