package/gawk: create awk symlink for host-gawk
authorHubert Lacote <hubert.lacote@youview.com>
Tue, 15 Jun 2021 14:03:02 +0000 (16:03 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 24 Jun 2021 21:35:51 +0000 (23:35 +0200)
This is to make sure that host packages that depend on `host-gawk` and that use
`awk` end up using `gawk`, instead of the `awk` symlink installed on the host
system.

On recent Debian-based distributions, `awk` is still symlinked to `mawk` [1].

[1] https://bugs.launchpad.net/ubuntu/+source/mawk/+bug/1841654

Signed-off-by: Hubert Lacote <hubert.lacote@youview.com>
Co-authored-by: Hubert Lacote <hubert.lacote@youview.com>
Co-authored-by: Vicente Olivert Riera <vincent.olivert.riera@youview.com>
[yann.morin.1998@free.fr: move after the target symlink hook]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gawk/gawk.mk

index 16906f6f93fe0e5735b5945fb9440eeef0e350e1..ae2bbe5422b4541329e5682e42ebbae387d7f015 100644 (file)
@@ -39,5 +39,11 @@ endef
 
 GAWK_POST_INSTALL_TARGET_HOOKS += GAWK_CREATE_SYMLINK
 
+define HOST_GAWK_CREATE_SYMLINK
+       ln -sf gawk $(HOST_DIR)/usr/bin/awk
+endef
+
+HOST_GAWK_POST_INSTALL_HOOKS += HOST_GAWK_CREATE_SYMLINK
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))