ruby: fix host build breakage
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Nov 2011 11:35:12 +0000 (08:35 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 26 Nov 2011 13:30:15 +0000 (14:30 +0100)
When building host-ruby with ncurses enabled on an x86_64 host we get a
"relocation R_X86_64_32 against `_nc_globals' can not be used when making
a shared object; recompile with -fPIC" error when building.
Just disable ncurses and readline support for the host version - we
don't need it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ruby/ruby.mk

index a34a2512abbe164daf478a30c45b31eb5836f85f..ad791f8f4ededd3050bf8ef44f74ee1d615e90ff 100644 (file)
@@ -11,8 +11,7 @@ HOST_RUBY_AUTORECONF = YES
 RUBY_DEPENDENCIES = host-ruby
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_CONF_OPT = --disable-install-doc --disable-rpath
-
-HOST_RUBY_CONF_OPT = --disable-install-doc
+HOST_RUBY_CONF_OPT = --disable-install-doc --without-ncurses --without-readline
 
 # Force optionals to build before we do
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)