package/genimage: new host-only package
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Mar 2013 08:19:43 +0000 (08:19 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Mar 2013 22:06:47 +0000 (23:06 +0100)
[Peter: wrap help text]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in.host
package/genimage/Config.in.host [new file with mode: 0644]
package/genimage/genimage.mk [new file with mode: 0644]

index 43f292c1741264c89f74657c4d3facd346bb08e8..c456d5dd78c59b4a9b6245263b74d9bc2a7fd30d 100644 (file)
@@ -3,6 +3,7 @@ menu "Host utilities"
 source "package/dfu-util/Config.in.host"
 source "package/dosfstools/Config.in.host"
 source "package/e2fsprogs/Config.in.host"
+source "package/genimage/Config.in.host"
 source "package/lpc3250loader/Config.in.host"
 source "package/omap-u-boot-utils/Config.in.host"
 source "package/openocd/Config.in.host"
diff --git a/package/genimage/Config.in.host b/package/genimage/Config.in.host
new file mode 100644 (file)
index 0000000..697dcda
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_HOST_GENIMAGE
+       bool "host genimage"
+       help
+         genimage is a tool to generate multiple filesystem and flash
+         images from a given root filesystem tree. genimage is
+         intended to be run in a fakeroot environment.
+         
+         Configuration is done is a config file parsed by
+         libconfuse. Options like the path to tools can be given in
+         environment variables, the config file or commandline
+         switches.
+         
+         http://www.pengutronix.de/software/genimage/
diff --git a/package/genimage/genimage.mk b/package/genimage/genimage.mk
new file mode 100644 (file)
index 0000000..6ed44a4
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# genimage
+#
+##############################################################
+
+GENIMAGE_VERSION        = 4
+GENIMAGE_SOURCE         = genimage-$(GENIMAGE_VERSION).tar.xz
+GENIMAGE_SITE           = http://www.pengutronix.de/software/genimage/download/
+GENIMAGE_DEPENDENCIES   = libconfuse
+GENIMAGE_LICENSE        = GPLv2
+
+$(eval $(host-autotools-package))