libtirpc: fix compilation error of rpcgen
authorDagg Stompler <daggs@gmx.com>
Fri, 29 Dec 2017 13:03:33 +0000 (15:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 29 Dec 2017 21:21:06 +0000 (22:21 +0100)
When compiling libtirpc, without RPC support available on the host
machine, the build of the rpcgen host program because it cannot find
the netconfig.h and rpc/types.h headers. Instead of relying on the
system-provided ones, let's use the ones included in the libtirpc
source code by patching the rpcgen build logic.

Signed-off-by: Dagg Stompler <daggs@gmx.com>
[Thomas: reword commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libtirpc/0003-Add-rpcgen-program-from-nfs-utils-sources.patch

index 1cf861417c9b500b9ed136685eef0343edccdcac..f2b15fe2f12eed751f440eafb4b41921d76105e8 100644 (file)
@@ -83,7 +83,7 @@ index 0000000..2277b6f
 --- /dev/null
 +++ b/rpcgen/Makefile.am
 @@ -0,0 +1,22 @@
-+COMPILE = $(CC_FOR_BUILD) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
++COMPILE = $(CC_FOR_BUILD) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) -I../tirpc $(AM_CPPFLAGS) \
 +      $(CPPFLAGS_FOR_BUILD) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD)
 +LINK = $(CC_FOR_BUILD) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(AM_LDFLAGS) $(LDFLAGS_FOR_BUILD) -o $@
 +